Endnote incompatibility

·

The newest version of Endnote is apparently incompatible with Word 2004. Now there's a surprise (Endnote barely manages to work with Panther as it is). [via darcusblog]