Installing Java Advanced Imaging in Ubuntu Hardy

·

The Java Advanced Imaging (JAI) library is required by GMapCreator, but there are few installation instructions. This worked:

  1. Download the appropriate platform-specific binary build of JAI. I used jai-1_1_3-lib-linux-i586-jre.bin. Set the execute permissions on this file with chmod a+x.
  2. cd to the JRE directory on your computer. I used /usr/lib/jvm/java-6-sun-1.6.0.06/jre (note: not /usr/lib/jvm/java-1.6.0-sun/jre - that'll give a "This is not a proper JRE directory" error).
  3. Run the downloaded binary installer as sudo, agree to the license terms and it should install jai_core.jar, jai_codec.jar, etc.